Grade Jobbnorge Status
Subscribe
to updates
Temporary service disruption
Minor incident
Jobbnorge.no
Jobadmin
Jobseeker
2026-02-13 14:53 CET
· 1 hour, 12 minutes
Updates
Resolved
Issue is now resolved.
February 13, 2026 · 14:59 CET
Investigating
We are currently investigating the issue.
February 13, 2026 · 14:53 CET
← Back